22

If you want to prevent auto-correct just once, tap the text box just after the word you're writing and that should cancel auto-correct. If you want to undo an auto-correct you just allowed by mistake, tap on the word that changed and the first suggestion should be your original word.


13

Go to the Settings app > Keyboard > Typing Settings and there will be a button to reset the dictionary. Note that this will delete all custom words. There is no way to delete a single word.


9

Go to settings > Keyboard > typing settings > tap language press to change > uncheck correct misspelt words. Now auto-correct will be turned off entirely. There doesn't seem to be a way to turn of auto-correct for just one word unless you add it into the dictionary.


7

Unfortunately it seems that there isn't any "standard" way to reset the dictionary in Windows 10 Mobile. Hopefully this will be added back in soon. I don't want to try this for fear it will actually work, but you could try adding a different keyboard, removing your default one, then reinstalling it. UPDATE: A post recently published by Microsoft states that ...


6

Go to Settings > Time & Language > Keyboard and tap on your keyboard in the list of keyboards. There you will find all autocorrect options. I believe "Correct misspelled words" is the setting you want to turn off.


5

The only way to remove a word from the dictionary is resetting your complete dictionary by going to Settings -> keyboard -> typing settings -> reset suggestions


3

Here's a related question. It's not the same on Windows 10 Mobile but here's what I found: Selecting on the word after it was auto-corrected suggests my spelling.After choosing my spelling the force-correct for that word appears to be disabled for the current email. I hope it's the same for other document types. Tapping right after the word, before it's ...


3

To turn off autocorrect: Settings Keyboard Typing Settings Keyboard Language (has "tap to change" label below it). In my case, it is "English" Uncheck "Correct mispelled words"


2

It looks like Microsoft forum and WPCentral forum both say that adding foul language to the dictionary is not currently possible.


2

Not possible in this release, sorry. If you want to send feedback to Microsoft about this, I've listed a number of feedback routes for wp on this page - http://dfwiki.devfish.net/technology.Microsoft-feedback-routes.ashx .


2

Windows 10 Mobile sometimes deviates from the settings of WP8.1 and it is very common for Bluetooth as well. What you can do is: Update your phone to the latest build of OS. Make sure that keyboard stuff for your selected language is downloaded. If not go to language settings and add that keyboard. Long tap the lower right toggle key of keyboard then go to ...


1

Go to Settings, Time & Language, Keyboard. Touch the keyboard you want to change, I assume English (US). Check / uncheck all the options as you would like.


1

You can change the word's case by selecting it and then press the SHIFT key on your keyboard. So let your device write "LinkedIn", select the word and change the case with SHIFT until you get "linkedin". I often use it on my Lumia 1020 because it always suggests "Smartphone" instead of "smartphone".


1

I have the same problem, it's so annoying. I don't want to turn off autocorrect, I just want it to stop autocorrecting correct words to stupid words, eg long to Lon, if to I. Just typing normally, not WordFlow. Language is English (New Zealand) Keyboard is English (UK) I've just reset suggestions under keyboard\advanced, and retyped the same message (in ...


1

One workaround is to use accented letters where there should be any. For example, replacing the u in F*ck with ū results in a word which can be added to the dictionary and will happily be suggested by the keyboard.


1

No, currently it is not possible to change the SIP (Software Input Panel, or on screen keyboard) in any way on Windows Phone 7. This means: no Swype, unless Microsoft adds it (or a way to customize SIPs) to any next version.


1

How do I prevent this from happening? Settings > Keyboard > Typing Settings > Click on the list of Languages (it says "press to change" beneath it). Uncheck "Correct misspelt words".


Only top voted, non community-wiki answers of a minimum length are eligible